SUSE SLED11 / SLES11 Security Update : libxml2 (SUSE-SU-2016:0030-1)

High Nessus Plugin ID 87862

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update fixes the following security issues :

- CVE-2015-1819 Enforce the reader to run in constant memory [bnc#928193]

- CVE-2015-7941 Fix out of bound read with crafted xml input by stopping parsing on entities boundaries errors [bnc#951734]

- CVE-2015-7942 Fix another variation of overflow in Conditional sections [bnc#951735]

- CVE-2015-8241 Avoid extra processing of MarkupDecl when EOF [bnc#956018]

- CVE-2015-8242 Buffer overead with HTML parser in push mode [bnc#956021]

- CVE-2015-8317 Return if the encoding declaration is broken or encoding conversion failed [bnc#956260]

- CVE-2015-5312 Fix another entity expansion issue [bnc#957105]

- CVE-2015-7497 Avoid an heap buffer overflow in xmlDictComputeFastQKey [bnc#957106]

- CVE-2015-7498 Processes entities after encoding conversion failures [bnc#957107]

- CVE-2015-7499 Add xmlHaltParser() to stop the parser / Detect incoherency on GROW [bnc#957109]

- CVE-2015-7500 Fix memory access error due to incorrect entities boundaries [bnc#957110]

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Software Development Kit 11-SP4 :

zypper in -t patch sdksp4-libxml2-20151221-12298=1

SUSE Linux Enterprise Software Development Kit 11-SP3 :

zypper in -t patch sdksp3-libxml2-20151221-12298=1

SUSE Linux Enterprise Server for VMWare 11-SP3 :

zypper in -t patch slessp3-libxml2-20151221-12298=1

SUSE Linux Enterprise Server 11-SP4 :

zypper in -t patch slessp4-libxml2-20151221-12298=1

SUSE Linux Enterprise Server 11-SP3 :

zypper in -t patch slessp3-libxml2-20151221-12298=1

SUSE Linux Enterprise Desktop 11-SP4 :

zypper in -t patch sledsp4-libxml2-20151221-12298=1

SUSE Linux Enterprise Desktop 11-SP3 :

zypper in -t patch sledsp3-libxml2-20151221-12298=1

SUSE Linux Enterprise Debuginfo 11-SP4 :

zypper in -t patch dbgsp4-libxml2-20151221-12298=1

SUSE Linux Enterprise Debuginfo 11-SP3 :

zypper in -t patch dbgsp3-libxml2-20151221-12298=1

To bring your system up-to-date, use 'zypper patch'.

See Also

https://bugzilla.suse.com/show_bug.cgi?id=928193

https://bugzilla.suse.com/show_bug.cgi?id=951734

https://bugzilla.suse.com/show_bug.cgi?id=951735

https://bugzilla.suse.com/show_bug.cgi?id=956018

https://bugzilla.suse.com/show_bug.cgi?id=956021

https://bugzilla.suse.com/show_bug.cgi?id=956260

https://bugzilla.suse.com/show_bug.cgi?id=957105

https://bugzilla.suse.com/show_bug.cgi?id=957106

https://bugzilla.suse.com/show_bug.cgi?id=957107

https://bugzilla.suse.com/show_bug.cgi?id=957109

https://bugzilla.suse.com/show_bug.cgi?id=957110

https://www.suse.com/security/cve/CVE-2015-1819/

https://www.suse.com/security/cve/CVE-2015-5312/

https://www.suse.com/security/cve/CVE-2015-7497/

https://www.suse.com/security/cve/CVE-2015-7498/

https://www.suse.com/security/cve/CVE-2015-7499/

https://www.suse.com/security/cve/CVE-2015-7500/

https://www.suse.com/security/cve/CVE-2015-7941/

https://www.suse.com/security/cve/CVE-2015-7942/

https://www.suse.com/security/cve/CVE-2015-8241/

https://www.suse.com/security/cve/CVE-2015-8242/

https://www.suse.com/security/cve/CVE-2015-8317/

http://www.nessus.org/u?2e3022a8

Plugin Details

Severity: High

ID: 87862

File Name: suse_SU-2016-0030-1.nasl

Version: 2.8

Type: local

Agent: unix

Published: 2016/01/12

Updated: 2019/09/11

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.1

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:libxml2, p-cpe:/a:novell:suse_linux:libxml2-doc, p-cpe:/a:novell:suse_linux:libxml2-python, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/01/05

Vulnerability Publication Date: 2015/08/14

Reference Information

CVE: CVE-2015-1819, CVE-2015-5312, CVE-2015-7497, CVE-2015-7498, CVE-2015-7499, CVE-2015-7500, CVE-2015-7941, CVE-2015-7942, CVE-2015-8241, CVE-2015-8242, CVE-2015-8317

BID: 75570