openSUSE Security Update : grub2 (openSUSE-2016-10)

Medium Nessus Plugin ID 87772


The remote openSUSE host is missing a security update.


- Fix buffer overflows when reading username and password.
(bsc#956631, CVE-2015-8370)

- Check MS-DOS header to find PE file header. (bsc#954126)

- Use dirname for copying Xen kernel and initrd to esp.

- Fix reading password by grub2-mkpasswd-pbdk2 without controlling tty. (bsc#954519)

- Add luks, gcry_rijndael and gcry_sha1 to signed EFI image to support LUKS partition in default setup.
(bsc#917427, bsc#955609)

- Expand list of grub.cfg search path in PV Xen guests for systems installed on btrfs snapshots. (bsc#946148, bsc#952539) This update was imported from the SUSE:SLE-12-SP1:Update update project.


Update the affected grub2 packages.

See Also

Plugin Details

Severity: Medium

ID: 87772

File Name: openSUSE-2016-10.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2016/01/07

Modified: 2016/01/07

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:grub2, p-cpe:/a:novell:opensuse:grub2-branding-upstream, p-cpe:/a:novell:opensuse:grub2-debuginfo, p-cpe:/a:novell:opensuse:grub2-i386-efi, p-cpe:/a:novell:opensuse:grub2-i386-pc, p-cpe:/a:novell:opensuse:grub2-snapper-plugin, p-cpe:/a:novell:opensuse:grub2-x86_64-efi, p-cpe:/a:novell:opensuse:grub2-x86_64-xen, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2016/01/06

Reference Information

CVE: CVE-2015-8370