FreeBSD : unzip -- multiple vulnerabilities (86c3c66e-b2f5-11e5-863a-b499baebfeaf)

Medium Nessus Plugin ID 87747


The remote FreeBSD host is missing a security-related update.


Gustavo Grieco reports :

Two issues were found in unzip 6.0 :

* A heap overflow triggered by unzipping a file with password (e.g unzip -p -P x

* A denegation of service with a file that never finishes unzipping (e.g. unzip


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 87747

File Name: freebsd_pkg_86c3c66eb2f511e5863ab499baebfeaf.nasl

Version: $Revision: 2.1 $

Type: local

Published: 2016/01/06

Modified: 2016/01/06

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:unzip, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2016/01/04

Vulnerability Publication Date: 2015/09/26

Reference Information

CVE: CVE-2015-7696, CVE-2015-7697