MariaDB 5.5 < 5.5.47 Multiple Vulnerabilities

high Nessus Plugin ID 87727
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MariaDB running on the remote host is 5.5.x prior to 5.5.47. It is, therefore, affected by multiple vulnerabilities :

- An unspecified flaw exists in the Server : Options subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2016-0505)

- An unspecified flaw exists in the Client subcomponent that allows a local attacker to gain elevated privileges. (CVE-2016-0546)

- An unspecified flaw exists in the Server : DML subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2016-0596)

- Multiple unspecified flaws exist in the Server :
Optimizer subcomponent that allows an authenticated, remote attacker to cause a denial of service.
(CVE-2016-0597, CVE-2016-0598, CVE-2016-0616)

- An unspecified flaw exists in the Server : InnoDB subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2016-0600)

- An unspecified flaw exists in the Server : Security :
Encryption subcomponent that allows an authenticated, remote attacker to impact integrity. (CVE-2016-0606, CVE-2016-0609)

- An unspecified flaw exists in the Server : UDF subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2016-0608)
- A security bypass vulnerability exists due to an incorrect implementation of the --ssl-verify-server-cert option. A man-in-the-middle attacker can exploit this to replace the server SSL certificate, resulting in a bypass of the client-side hostname verification.
(MDEV-9212)

Solution

Upgrade to MariaDB version 5.5.47 or later.

See Also

https://mariadb.atlassian.net/browse/MDEV-9212

Plugin Details

Severity: High

ID: 87727

File Name: mariadb_5_5_47.nasl

Version: 1.14

Type: remote

Family: Databases

Published: 1/4/2016

Updated: 11/20/2019

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 6.6

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 5.6

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 7

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 12/8/2015

Vulnerability Publication Date: 11/30/2015

Reference Information

CVE: CVE-2016-0505, CVE-2016-0546, CVE-2016-0596, CVE-2016-0597, CVE-2016-0598, CVE-2016-0600, CVE-2016-0606, CVE-2016-0608, CVE-2016-0609, CVE-2016-0616, CVE-2016-2047