MariaDB 10.0.x < 10.0.23 Multiple Vulnerabilities

High Nessus Plugin ID 87725

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MariaDB running on the remote host is 10.0.x prior to 10.0.23. It is, therefore, affected by multiple vulnerabilities :

- An unspecified flaw exists in the Server : Options subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2016-0505)

- An unspecified flaw exists in the Client subcomponent that allows a local attacker to gain elevated privileges. (CVE-2016-0546)

- An unspecified flaw exists in the Server : DML subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2016-0596)

- Multiple unspecified flaws exist in the Server :
Optimizer subcomponent that allows an authenticated, remote attacker to cause a denial of service.
(CVE-2016-0597, CVE-2016-0598, CVE-2016-0616)

- An unspecified flaw exists in the Server : InnoDB subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2016-0600)

- An unspecified flaw exists in the Server : Security :
Encryption subcomponent that allows an authenticated, remote attacker to impact integrity. (CVE-2016-0606, CVE-2016-0609)

- An unspecified flaw exists in the Server : UDF subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2016-0608)

- A flaw exists in the check_fk_parent_table_access() function in sql_parse.cc that is triggered when performing database name conversions. An authenticated, remote attacker can exploit this to crash the database, resulting in a denial of service.

- An overflow condition exists in the XMLColumns() function in tabxml.cpp due to improper validation of user-supplied input. An authenticated, remote attacker can exploit this to cause a buffer overflow, resulting in a denial of service condition or the execution of arbitrary code.

- An unspecified flaw exists that is triggered when handling UPDATE queries with JOIN. An authenticated, remote attacker can exploit this to crash the database, resulting in a denial of service.

- A flaw exists in mysql_upgrade due to leaking plaintext password information to the process listing when spawning a shell process to execute mysqlcheck. A local attacker can exploit this to disclose sensitive password information.

- An unspecified flaw exists that is triggered during the handling of 'View' or 'Derived' fields. An authenticated, remote attacker can exploit this to crash the database, resulting in a denial of service.

- An unspecified flaw exists in i_s.cc that is triggered during the handling of buffer pages. An authenticated, remote attacker can exploit this to crash the database, resulting in a denial of service.

- An unspecified flaw exists in ha_innodb.cc that is triggered when handling lower case table names. An authenticated, remote attacker can exploit this to crash the database, resulting in a denial of service.

- A flaw exists in the row_merge_sort() function that is triggered when handling FT-index creation. An authenticated, remote attacker can exploit this to crash the database, resulting in a denial of service.

- An overflow condition exists in the decimal2string() function in decimal.c due to improper validation of user-supplied input when handling decimals in SELECT statements. An authenticated, remote attacker can exploit this to crash the database, resulting in a denial of service condition.

- A flaw exists in the mysql_prepare_create_table() function due to improper handling of a comma buffer that is greater than zero. An authenticated, remote attacker can exploit this to cause a denial of service condition.

- A flaw exists in the decimal2string() function due to improper handling of decimal precision greater than 40.
An authenticated, remote attacker can exploit this to crash the server, resulting in a denial of service condition.

- A security bypass vulnerability exists due to an incorrect implementation of the --ssl-verify-server-cert option. A man-in-the-middle attacker can exploit this to replace the server SSL certificate, resulting in a bypass of the client-side hostname verification.
(MDEV-9212)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MariaDB version 10.0.23 or later.

See Also

https://mariadb.org/mariadb-10-0-23-now-available/

https://mariadb.com/kb/en/mariadb/mariadb-10023-release-notes/

https://mariadb.com/kb/en/library/mariadb-10023-changelog/

https://mariadb.atlassian.net/browse/MDEV-7050

https://mariadb.atlassian.net/browse/MDEV-8407

https://mariadb.atlassian.net/browse/MDEV-9212

Plugin Details

Severity: High

ID: 87725

File Name: mariadb_10_0_23.nasl

Version: 1.16

Type: remote

Family: Databases

Published: 2016/01/04

Updated: 2019/11/20

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2016-0546

CVSS v2.0

Base Score: 7.2

Temporal Score: 5.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/12/10

Vulnerability Publication Date: 2014/10/28

Reference Information

CVE: CVE-2016-0505, CVE-2016-0546, CVE-2016-0596, CVE-2016-0597, CVE-2016-0598, CVE-2016-0600, CVE-2016-0606, CVE-2016-0608, CVE-2016-0609, CVE-2016-0616, CVE-2016-2047

BID: 81066, 81088, 81130, 81151, 81176, 81182, 81188, 81226, 81258, 81810