openSUSE Security Update : cups-filters (openSUSE-2015-954)

High Nessus Plugin ID 87628

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for cups-filters fixes the following issues :

- cups-filters-1.0.58-CVE-2015-8327-et_alii.patch adds back tick and semicolon to the list of illegal shell escape characters to fix CVE-2015-8327 and CVE-2015-8560 (boo#957531).

Solution

Update the affected cups-filters packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=957531

Plugin Details

Severity: High

ID: 87628

File Name: openSUSE-2015-954.nasl

Version: Revision: 2.2

Type: local

Agent: unix

Published: 2015/12/29

Updated: 2016/10/13

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 7.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:cups-filters, p-cpe:/a:novell:opensuse:cups-filters-cups-browsed, p-cpe:/a:novell:opensuse:cups-filters-cups-browsed-debuginfo, p-cpe:/a:novell:opensuse:cups-filters-debuginfo, p-cpe:/a:novell:opensuse:cups-filters-debugsource, p-cpe:/a:novell:opensuse:cups-filters-devel, p-cpe:/a:novell:opensuse:cups-filters-foomatic-rip, p-cpe:/a:novell:opensuse:cups-filters-foomatic-rip-debuginfo, p-cpe:/a:novell:opensuse:cups-filters-ghostscript, p-cpe:/a:novell:opensuse:cups-filters-ghostscript-debuginfo, cpe:/o:novell:opensuse:13.2

Patch Publication Date: 2015/12/26

Reference Information

CVE: CVE-2015-8327, CVE-2015-8560