FreeBSD : dpkg -- stack-based buffer overflow (876768aa-ab1e-11e5-8a30-5453ed2e2b49)

High Nessus Plugin ID 87613

Synopsis

The remote FreeBSD host is missing one or more security-related updates.

Description

Salvatore Bonaccorso reports :

Hanno Boeck discovered a stack-based buffer overflow in the dpkg-deb component of dpkg, the Debian package management system. This flaw could potentially lead to arbitrary code execution if a user or an automated system were tricked into processing a specially crafted Debian binary package (.deb) in the old style Debian binary package format.

Solution

Update the affected packages.

See Also

https://www.openwall.com/lists/oss-security/2015/11/26/3

http://www.nessus.org/u?0a8b937a

http://www.nessus.org/u?1c0ffca8

Plugin Details

Severity: High

ID: 87613

File Name: freebsd_pkg_876768aaab1e11e58a305453ed2e2b49.nasl

Version: 2.3

Type: local

Published: 2015/12/29

Updated: 2018/12/19

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:dpkg, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/12/25

Vulnerability Publication Date: 2015/11/26

Reference Information

CVE: CVE-2015-0860