openSUSE Security Update : libpng12 (openSUSE-2015-902)

High Nessus Plugin ID 87445

Synopsis

The remote openSUSE host is missing a security update.

Description

This update fixes the following security issue :

- CVE-2015-8126 Buffer overflow vulnerabilities in png_get_PLTE/png_set_PLTE functions (bsc#954980)

Solution

Update the affected libpng12 packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=954980

Plugin Details

Severity: High

ID: 87445

File Name: openSUSE-2015-902.nasl

Version: Revision: 2.3

Type: local

Agent: unix

Published: 2015/12/17

Updated: 2016/03/21

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libpng12-0, p-cpe:/a:novell:opensuse:libpng12-0-32bit, p-cpe:/a:novell:opensuse:libpng12-0-debuginfo, p-cpe:/a:novell:opensuse:libpng12-0-debuginfo-32bit, p-cpe:/a:novell:opensuse:libpng12-compat-devel, p-cpe:/a:novell:opensuse:libpng12-compat-devel-32bit, p-cpe:/a:novell:opensuse:libpng12-debugsource, p-cpe:/a:novell:opensuse:libpng12-devel, p-cpe:/a:novell:opensuse:libpng12-devel-32bit, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/12/14

Reference Information

CVE: CVE-2015-8126