MySQL 5.7.x < 5.7.10 Multiple DoS

High Nessus Plugin ID 87421

Synopsis

The remote database server is affected by multiple denial of service vulnerabilities.

Description

The version of MySQL running on the remote host is 5.7.x prior to 5.7.10. It is, therefore, potentially affected by the following vulnerabilities :

- Multiple unspecified flaws exists in the Server : DML subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2016-0503, CVE-2016-0504)

- An unspecified flaw exists in the Server : Options subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2016-0505)

- An unspecified flaw exists in the Client subcomponent that allows a local attacker to gain elevated privileges. (CVE-2016-0546)

- Multiple unspecified flaws exist in the Server :
Optimizer subcomponent that allows an authenticated, remote attacker to cause a denial of service.
(CVE-2016-0597, CVE-2016-0598, CVE-2016-0599, CVE-2016-0611)

- An unspecified flaw exists in the Server : InnoDB subcomponent that allows an authenticated, remote attacker to cause a denial of service.
(CVE-2016-0600)

- An unspecified flaw exists in the Server : Partition subcomponent that allows an authenticated, remote attacker to cause a denial of service.
(CVE-2016-0601)

- An unspecified flaw exists in the Server : Security :
Encryption subcomponent that allows an authenticated, remote attacker to impact integrity. (CVE-2016-0606, CVE-2016-0609)

- An unspecified flaw exists in the Server : Replication subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2016-0607)

- An unspecified flaw exists in the Server : UDF subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2016-0608)

- A denial of service vulnerability exists due to repeatedly executing a prepared statement when the default database has been changed. An authenticated, remote attacker can exploit this to cause the server to exit.

- A denial of service vulnerability exists due to a use-after-free error that is triggered when generated column expressions are reevaluated. An authenticated, remote attacker can exploit this to deference already freed memory, thus causing the server to exit.

- A denial of service vulnerability exists due to a flaw that is triggered when selecting DECIMAL values into user-defined variables. An authenticated, remote attacker can exploit this to cause the server to exit.

- A denial of service vulnerability exists due to a use-after-free error in spatial functions. An authenticated, remote attacker can exploit this to deference already freed memory, thus causing the server to exit.

- A flaw exists in the Server : InnoDB subcomponent due to a failure to check for destination files with the same name when using the ALTER TABLE operation to convert a table to an InnoDB file-per-table tablespace. An authenticated, remote attacker can exploit this to cause a denial of service.

- A NULL pointer dereference flaw exists in the Server :
InnoDB subcomponent due to a failure to properly check the return value of an unspecified function call used in a DROP TABLE operation. An authenticated, remote attacker can exploit this to cause a denial of service.

- A flaw exists in the Server : InnoDB subcomponent in the row_quiesce_table_start() function that is triggered when running a 'FLUSH TABLE ... FOR EXPORT' operation on a partitioned table with partitions residing in a system or general tablespace. An authenticated, remote attacker can exploit this to cause a denial of service condition.

- A flaw exists in the Server : InnoDB subcomponent that is triggered when handling 'ALTER TABLE ... DISCARD TABLESPACE' operations. An authenticated, remote attacker can exploit this to cause a denial of service condition.

- A flaw exists in the Server : InnoDB subcomponent that is triggered when handling 'TRUNCATE TABLE' operations.
An authenticated, remote attacker can exploit this to cause a denial of service condition.

- A flaw exists in the Server : InnoDB subcomponent that is triggered when handling 'SELECT ... FOR UPDATE' operations on tables that only contain virtual columns and virtual column indexes. An authenticated, remote attacker can exploit this to cause a denial of service condition.

- A flaw exists in the Server : InnoDB subcomponent that is triggered when handling in-place operations that rebuild tables with multiple indexed virtual columns. An authenticated, remote attacker can exploit this to cause a denial of service condition.

- A denial of service vulnerability exists that is triggered when updating views using ALL comparison operators on subqueries that select from indexed columns in the main table. An authenticated, remote attacker can exploit this to cause the server to exit, resulting in a denial of service condition.

- A flaw exists in the Server : InnoDB subcomponent that is triggered when handling ALTER TABLE operations. An authenticated, remote attacker can exploit this to cause a denial of service condition.

- A remote code execution vulnerability exists due to improper validation of user-supplied input to the strcpy() and sprintf() functions. An authenticated, remote attacker can exploit this to cause a buffer overflow, resulting in a denial of service condition or the execution of arbitrary code.

- A denial of service vulnerability exists due to a flaw that is triggered when selecting DECIMAL values into user-defined variables. An authenticated, remote attacker can exploit this to cause the server to exit.

- A denial of service vulnerability exists that is triggered when handling concurrent FLUSH PRIVILEGES and REVOKE or GRANT statements. An authenticated, remote attacker can exploit this to cause the server to exit by triggering an invalid memory access to proxy user information.

- A denial of service vulnerability exists that is triggered on the second execution of a prepared statement where an ORDER BY clause references a column position. An authenticated, remote attacker can exploit this to cause the server to exit.

Solution

Upgrade to MySQL version 5.7.10 or later.

See Also

https://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-10.html

http://www.nessus.org/u?75a4a4fb

http://www.nessus.org/u?6405bf15

Plugin Details

Severity: High

ID: 87421

File Name: mysql_5_7_10.nasl

Version: 1.14

Type: remote

Family: Databases

Published: 2015/12/16

Updated: 2019/01/02

Dependencies: 91823, 10719

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/12/07

Vulnerability Publication Date: 2015/12/07

Reference Information

CVE: CVE-2016-0503, CVE-2016-0504, CVE-2016-0505, CVE-2016-0546, CVE-2016-0597, CVE-2016-0598, CVE-2016-0599, CVE-2016-0600, CVE-2016-0601, CVE-2016-0606, CVE-2016-0607, CVE-2016-0608, CVE-2016-0609, CVE-2016-0611