MariaDB < 5.5.46 Multiple Vulnerabilities

medium Nessus Plugin ID 87210
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MariaDB running on the remote host is prior to 5.5.46.
It is, therefore, affected by the following vulnerabilities :

- Multiple unspecified flaws exist related to the Partition subcomponent that allow an authenticated, remote attacker to cause a denial of service.
(CVE-2015-4802, CVE-2015-4792)

- An unspecified flaw exists related to the Query Cache subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2015-4807)

- An unspecified flaw exists related to the DDL subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2015-4815)

- An unspecified flaw exists related to the Types subcomponent that allows an authenticated, remote attacker to gain access to sensitive information.
(CVE-2015-4826)

- An unspecified flaw exists related to the Security:Privileges subcomponent that allows an authenticated, remote attacker to affect the integrity of the system. No other details are available.
(CVE-2015-4830)

- An unspecified flaw exists related to the SP subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2015-4836)

- Multiple unspecified flaws exist related to the DML subcomponent that allow an authenticated, remote attacker to cause a denial of service. (CVE-2015-4858, CVE-2015-4913)

- An unspecified flaw exists related to the InnoDB subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2015-4861)

- An unspecified flaw exists related to the Parser subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2015-4870)

- A flaw exists in the mysql_prepare_create_table() function due to improper handling of a comma buffer that is greater than zero. An authenticated, remote attacker can exploit this to cause a denial of service condition.

Solution

Upgrade to MariaDB version 5.5.46 or later.

See Also

https://mariadb.org/mariadb-5-5-46-now-available/

https://mariadb.com/kb/en/mariadb/mariadb-5546-release-notes/

https://mariadb.com/kb/en/mariadb/mariadb-5546-changelog/

https://mariadb.atlassian.net/browse/MDEV-7050

Plugin Details

Severity: Medium

ID: 87210

File Name: mariadb_5_5_46.nasl

Version: 1.10

Type: remote

Family: Databases

Published: 12/4/2015

Updated: 11/20/2019

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2015-4830

VPR

Risk Factor: Medium

Score: 4.2

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3.1

Vector: AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/12/2015

Vulnerability Publication Date: 10/12/2015

Reference Information

CVE: CVE-2015-4792, CVE-2015-4802, CVE-2015-4807, CVE-2015-4815, CVE-2015-4826, CVE-2015-4830, CVE-2015-4836, CVE-2015-4858, CVE-2015-4861, CVE-2015-4870, CVE-2015-4913

BID: 77137, 77145, 77153, 77165, 77171, 77190, 77205, 77208, 77222, 77228, 77237