SUSE SLED12 / SLES12 Security Update : strongswan (SUSE-SU-2015:2183-1)

Medium Nessus Plugin ID 87201


The remote SUSE host is missing one or more security updates.


The strongswan package was updated to fix the following security issue :

- CVE-2015-8023: Fixed an authentication bypass vulnerability in the eap-mschapv2 plugin (bsc#953817).

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Server 12 :

zypper in -t patch SUSE-SLE-SERVER-12-2015-934=1

SUSE Linux Enterprise Desktop 12 :

zypper in -t patch SUSE-SLE-DESKTOP-12-2015-934=1

To bring your system up-to-date, use 'zypper patch'.

See Also

Plugin Details

Severity: Medium

ID: 87201

File Name: suse_SU-2015-2183-1.nasl

Version: $Revision: 2.4 $

Type: local

Agent: unix

Published: 2015/12/04

Modified: 2016/05/02

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:strongswan, p-cpe:/a:novell:suse_linux:strongswan-debugsource, p-cpe:/a:novell:suse_linux:strongswan-hmac, p-cpe:/a:novell:suse_linux:strongswan-ipsec, p-cpe:/a:novell:suse_linux:strongswan-ipsec-debuginfo, p-cpe:/a:novell:suse_linux:strongswan-libs0, p-cpe:/a:novell:suse_linux:strongswan-libs0-debuginfo, cpe:/o:novell:suse_linux:12

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/12/03

Reference Information

CVE: CVE-2015-8023

OSVDB: 130318