openSUSE Security Update : dracut (openSUSE-2015-846)

Medium Nessus Plugin ID 87189


The remote openSUSE host is missing a security update.


This update for dracut fixes the following issues :

- Skip ibft setup via dhcp if dhcp ip is (boo#953361) Added 0312-iscsi-skip-ibft-invalid-dhcp.patch

- Modify 0169-enabled-warning-for-failed-kernel-modules-per-defau l.patch

- Add notice (boo#952491)

- Refresh patches with line offsets: M M 0182-fix_add_drivers_hang.patch M 0183-kernel-modules-Fix-storage-module-selection-for-sdh c.patch

- Modify 0181-load-xhci-pci.patch :

- Add hid-logitech-hidpp

- Ignore errors for xhci-pci, ehci-platform and hid-logitech-hidpp

- Boo#952491, boo#935563 and boo#953035

- Add 0311-less_pointless_module_errors.patch (boo#952491 and boo#935563)

- Don't warn if installing built-in modules fails

- Don't print the error message twice

- Modify 0144-90crypt-fixed-crypttab_contains-to-also-work-with-d e.patch and 0169-Enabled-Warning-for-failed-kernel-modules-per-defau l.patch

- Fixes boo#935338

- Use mktemp instead of hardcoded filenames, possible vulnerability


Update the affected dracut packages.

See Also

Plugin Details

Severity: Medium

ID: 87189

File Name: openSUSE-2015-846.nasl

Version: $Revision: 2.1 $

Type: local

Agent: unix

Published: 2015/12/04

Modified: 2015/12/04

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:dracut, p-cpe:/a:novell:opensuse:dracut-debuginfo, p-cpe:/a:novell:opensuse:dracut-debugsource, p-cpe:/a:novell:opensuse:dracut-fips, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/12/01