openSUSE Security Update : miniupnpc (openSUSE-2015-789)

Medium Nessus Plugin ID 87006

Synopsis

The remote openSUSE host is missing a security update.

Description

MiniUPnP was updated to fix one security issue.

The following vulnerability was fixed :

- CVE-2015-6031: XML parser buffer overflow (boo#950759)

Solution

Update the affected miniupnpc packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=950759

Plugin Details

Severity: Medium

ID: 87006

File Name: openSUSE-2015-789.nasl

Version: Revision: 2.1

Type: local

Agent: unix

Published: 2015/11/23

Updated: 2015/11/23

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libminiupnpc-devel, p-cpe:/a:novell:opensuse:libminiupnpc10, p-cpe:/a:novell:opensuse:libminiupnpc10-32bit, p-cpe:/a:novell:opensuse:libminiupnpc10-debuginfo, p-cpe:/a:novell:opensuse:libminiupnpc10-debuginfo-32bit, p-cpe:/a:novell:opensuse:miniupnpc, p-cpe:/a:novell:opensuse:miniupnpc-debuginfo, p-cpe:/a:novell:opensuse:python-miniupnpc, p-cpe:/a:novell:opensuse:python-miniupnpc-debuginfo, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/11/14

Reference Information

CVE: CVE-2015-6031