Nessus 5.x < 5.2.12 / 6.x < 6.4 Multiple OpenSSL Vulnerabilities

High Nessus Plugin ID 86949


The remote Nessus installation is affected by multiple denial of service vulnerabilities in the bundled OpenSSL component.


According to its version, the installation of Tenable Nessus running on the remote host is version 5.x prior to 5.2.12 or 6.x prior to 6.4.
It is, therefore, affected by multiple denial of service vulnerabilities in the bundled OpenSSL component :

- A denial of service vulnerability exists when processing an ECParameters structure due to an infinite loop that occurs when a specified curve is over a malformed binary polynomial field. A remote attacker can exploit this to perform a denial of service against any system that processes public keys, certificate requests, or certificates. This includes TLS clients and TLS servers with client authentication enabled. (CVE-2015-1788)

- A denial of service vulnerability exists due to improper validation of the content and length of the ASN1_TIME string by the X509_cmp_time() function. A remote attacker can exploit this, via a malformed certificate and CRLs of various sizes, to cause a segmentation fault, resulting in a denial of service condition. TLS clients that verify CRLs are affected. TLS clients and servers with client authentication enabled may be affected if they use custom verification callbacks.


Upgrade to Tenable Nessus 5.2.12 / 6.4 or later.

See Also

Plugin Details

Severity: High

ID: 86949

File Name: nessus_tns_2015_07.nasl

Version: $Revision: 1.9 $

Type: remote

Family: Misc.

Published: 2015/11/19

Modified: 2017/03/07

Dependencies: 10147

Risk Information

Risk Factor: High


Base Score: 8.5

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND


Base Score: 8.2

Temporal Score: 7.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:tenable:nessus

Required KB Items: installed_sw/nessus

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/06/30

Vulnerability Publication Date: 2015/06/30

Reference Information

CVE: CVE-2015-1788, CVE-2015-1789

BID: 75156, 75158

OSVDB: 123172, 123173