openSUSE Security Update : putty (openSUSE-2015-766)

Medium Nessus Plugin ID 86924


The remote openSUSE host is missing a security update.


PuTTY was updated to 0.66 to fix security issues and bugs.

The following vulnerabilities were fixed :

- CVE-2015-5309: Malicious ECH control sequences could have caused an integer overflow, buffer underrun in terminal emulator bnc#954191

Also contains all bug fixes up to the 0.66 release.


Update the affected putty packages.

See Also

Plugin Details

Severity: Medium

ID: 86924

File Name: openSUSE-2015-766.nasl

Version: $Revision: 2.3 $

Type: local

Agent: unix

Published: 2015/11/19

Modified: 2015/12/09

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:putty, p-cpe:/a:novell:opensuse:putty-debuginfo, p-cpe:/a:novell:opensuse:putty-debugsource, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/11/09

Reference Information

CVE: CVE-2015-5309