FreeBSD : powerdns -- Denial of Service (56665ccb-8723-11e5-9b13-14dae9d210b8)

Medium Nessus Plugin ID 86806


The remote FreeBSD host is missing a security-related update.


PowerDNS reports :

A bug was found using afl-fuzz in our packet parsing code. This bug, when exploited, causes an assertion error and consequent termination of the the pdns_server process, causing a Denial of Service.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 86806

File Name: freebsd_pkg_56665ccb872311e59b1314dae9d210b8.nasl

Version: $Revision: 2.2 $

Type: local

Published: 2015/11/10

Modified: 2015/11/19

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:powerdns, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/11/09

Vulnerability Publication Date: 2015/11/03

Reference Information

CVE: CVE-2015-5311