openSUSE Security Update : bouncycastle (openSUSE-2015-705)

Medium Nessus Plugin ID 86740


The remote openSUSE host is missing a security update.


bouncycastle was updated to version 1.53 to fix one security issue.

This security issue was fixed :

- CVE-2015-7940: Invalid curve attack (bsc#951727).


Update the affected bouncycastle packages.

See Also

Plugin Details

Severity: Medium

ID: 86740

File Name: openSUSE-2015-705.nasl

Version: $Revision: 2.3 $

Type: local

Agent: unix

Published: 2015/11/05

Modified: 2015/11/20

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:bouncycastle, p-cpe:/a:novell:opensuse:bouncycastle-javadoc, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2015/10/23

Reference Information

CVE: CVE-2015-7940