PowerDNS Authoritative Server 3.4.x < 3.4.6 distributor.hh Packet Handling DoS

high Nessus Plugin ID 86699
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote DNS server is affected by a denial of service vulnerability.


According to its self-reported version number, the version of the PowerDNS Authorative Server listening on the remote host is version 3.4.x prior to 3.4.6. It is, therefore, affected by a denial of service vulnerability due to an unspecified flaw in 'pdns/distributor.hh' related to DNS packet parsing and generation. A remote attacker can exploit this vulnerability, via crafted query packets, to crash the server.

Note that Nessus has not attempted to exploit this issue but has instead relied only on the application's self-reported version number.
Also, Nessus has not checked for the presence of the patch or the workaround.


Upgrade to PowerDNS Authoritative Server 3.4.6 or later.
Alternatively, apply the patch or workaround referenced in the vendor advisory.

See Also



Plugin Details

Severity: High

ID: 86699

File Name: powerdns_authoritative_server_dos.nasl

Version: 1.5

Type: remote

Family: DNS

Published: 11/2/2015

Updated: 11/15/2018

Dependencies: pdns_version.nasl

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:powerdns:powerdns, cpe:/a:powerdns:authoritative

Required KB Items: pdns/version_full, pdns/version_source, pdns/type, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 9/2/2015

Vulnerability Publication Date: 9/2/2015

Reference Information

CVE: CVE-2015-5230

BID: 76638