openSUSE Security Update : nodejs (openSUSE-2015-680)

Medium Nessus Plugin ID 86667


The remote openSUSE host is missing a security update.


nodejs was updated to version 4.2.1 to fix one security issue.

This security issue was fixed :

- CVE-2015-7384: HTTP Denial of Service Vulnerability (bsc#948602).

Various other issues were fixed, please see the changelog.


Update the affected nodejs packages.

See Also

Plugin Details

Severity: Medium

ID: 86667

File Name: openSUSE-2015-680.nasl

Version: $Revision: 2.5 $

Type: local

Agent: unix

Published: 2015/10/30

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:nodejs, p-cpe:/a:novell:opensuse:nodejs-debuginfo, p-cpe:/a:novell:opensuse:nodejs-debugsource, p-cpe:/a:novell:opensuse:nodejs-devel, p-cpe:/a:novell:opensuse:nodejs-npm, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/11/09

Reference Information

CVE: CVE-2015-7384