SUSE SLED12 / SLES12 Security Update : gcc48 (SUSE-SU-2015:1833-1)

Medium Nessus Plugin ID 86648


The remote SUSE host is missing one or more security updates.


This update for GCC 4.8 provides the following fixes :

- Fix C++11 std::random_device short read issue that could lead to predictable randomness. (CVE-2015-5276, bsc#945842)

- Fix linker segmentation fault when building SLOF on ppc64le. (bsc#949000)

- Fix no_instrument_function attribute handling on PPC64 with

-mprofile-kernel. (bsc#947791)

- Fix internal compiler error with aarch64 target using PCH and builtin functions. (bsc#947772)

- Fix libffi issues on aarch64. (bsc#948168)

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Workstation Extension 12 :

zypper in -t patch SUSE-SLE-WE-12-2015-756=1

SUSE Linux Enterprise Software Development Kit 12 :

zypper in -t patch SUSE-SLE-SDK-12-2015-756=1

SUSE Linux Enterprise Server 12 :

zypper in -t patch SUSE-SLE-SERVER-12-2015-756=1

SUSE Linux Enterprise Desktop 12 :

zypper in -t patch SUSE-SLE-DESKTOP-12-2015-756=1

To bring your system up-to-date, use 'zypper patch'.

See Also

Plugin Details

Severity: Medium

ID: 86648

File Name: suse_SU-2015-1833-1.nasl

Version: $Revision: 2.4 $

Type: local

Agent: unix

Published: 2015/10/29

Modified: 2016/04/05

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:cpp48, p-cpe:/a:novell:suse_linux:cpp48-debuginfo, p-cpe:/a:novell:suse_linux:gcc48, p-cpe:/a:novell:suse_linux:gcc48-c++, p-cpe:/a:novell:suse_linux:gcc48-c++-debuginfo, p-cpe:/a:novell:suse_linux:gcc48-debuginfo, p-cpe:/a:novell:suse_linux:gcc48-debugsource, p-cpe:/a:novell:suse_linux:gcc48-gij, p-cpe:/a:novell:suse_linux:gcc48-gij-debuginfo, p-cpe:/a:novell:suse_linux:gcc48-locale, p-cpe:/a:novell:suse_linux:libasan0, p-cpe:/a:novell:suse_linux:libasan0-32bit-debuginfo, p-cpe:/a:novell:suse_linux:libasan0-debuginfo, p-cpe:/a:novell:suse_linux:libffi48-debugsource, p-cpe:/a:novell:suse_linux:libgcj48, p-cpe:/a:novell:suse_linux:libgcj48-debuginfo, p-cpe:/a:novell:suse_linux:libgcj48-debugsource, p-cpe:/a:novell:suse_linux:libgcj48-jar, p-cpe:/a:novell:suse_linux:libgcj_bc1, p-cpe:/a:novell:suse_linux:libstdc++48-devel, cpe:/o:novell:suse_linux:12

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/10/06

Reference Information

CVE: CVE-2015-5276

OSVDB: 127770