Fortinet FortiAnalyzer FortiOS 5.0.x < 5.0.11 / 5.2.x < 5.2.2 Dataset Reports XSS

Medium Nessus Plugin ID 86470


The remote host is affected by a cross-site scripting vulnerability.


The Fortinet FortiAnalyzer FortiOS version running on the remote host is 5.0.x prior to 5.0.11 or 5.2.x prior to 5.2.2. It is, therefore, affected by a cross-site scripting vulnerability in the advanced dataset reports page due to a failure to properly sanitize user-supplied input to the 'sql-query' GET parameter before returning it to users. An unauthenticated, remote attacker can exploit this, via a crafted request, to execute arbitrary script code or HTML in the user's browser session.


Upgrade to Fortinet FortiOS version 5.0.11 / 5.2.2.

See Also

Plugin Details

Severity: Medium

ID: 86470

File Name: fortianalyzer_FG-IR-15-005.nasl

Version: 1.5

Type: local

Published: 2015/10/21

Modified: 2018/11/15

Dependencies: 73522

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:fortinet:fortianalyzer_firmware

Required KB Items: Host/Fortigate/model, Host/Fortigate/version, Host/Fortigate/build

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2015/02/25

Vulnerability Publication Date: 2015/02/25

Reference Information

CVE: CVE-2015-3620

BID: 74646