DNN (DotNetNuke) < 7.4.2 Multiple Vulnerabilities

Medium Nessus Plugin ID 86445

Synopsis

The remote web server contains an ASP.NET application that is affected by multiple vulnerabilities.

Description

The version of DNN installed on the remote host is affected by multiple vulnerabilities :

- An unspecified cross-site scripting vulnerability exists due to a failure to properly sanitize content used by the tabs control. An unauthenticated, remote attacker can exploit this to execute arbitrary script code in the user's browser session. (VulnDB 128534)

- A flaw exists in user registration modes due to a failure to revalidate that site registration is set to 'none'. An attacker can exploit this to register spam accounts, thus circumventing DNN's protections.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to DNN version 7.4.2 or later.

See Also

http://www.dnnsoftware.com/platform/manage/security-center

Plugin Details

Severity: Medium

ID: 86445

File Name: dotnetnuke_7_4_2.nasl

Version: 1.5

Type: remote

Published: 2015/10/20

Modified: 2018/08/08

Dependencies: 42978

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:dotnetnuke:dotnetnuke

Required KB Items: installed_sw/DNN

Patch Publication Date: 2015/10/06

Vulnerability Publication Date: 2015/10/06