openSUSE Security Update : polkit (openSUSE-2015-655)

Medium Nessus Plugin ID 86390


The remote openSUSE host is missing a security update.


Polkit was updated to 0.113 to fix four security issues.

The following vulnerabilities were fixed :

- CVE-2015-4625: a local privilege escalation due to predictable authentication session cookie values.

- CVE-2015-3256: various memory corruption vulnerabilities in use of the JavaScript interpreter, possibly leading to local privilege escalation. (boo#943816)

- CVE-2015-3255: a memory corruption vulnerability in handling duplicate action IDs, possibly leading to local privilege escalation. (boo#939246)

- CVE-2015-3218: Allowed any local user to crash polkitd.


Update the affected polkit packages.

See Also

Plugin Details

Severity: Medium

ID: 86390

File Name: openSUSE-2015-655.nasl

Version: $Revision: 2.2 $

Type: local

Agent: unix

Published: 2015/10/15

Modified: 2015/10/28

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libpolkit0, p-cpe:/a:novell:opensuse:libpolkit0-32bit, p-cpe:/a:novell:opensuse:libpolkit0-debuginfo, p-cpe:/a:novell:opensuse:libpolkit0-debuginfo-32bit, p-cpe:/a:novell:opensuse:polkit, p-cpe:/a:novell:opensuse:polkit-debuginfo, p-cpe:/a:novell:opensuse:polkit-debugsource, p-cpe:/a:novell:opensuse:polkit-devel, p-cpe:/a:novell:opensuse:polkit-devel-debuginfo, p-cpe:/a:novell:opensuse:typelib-1_0-Polkit-1_0, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/10/06

Reference Information

CVE: CVE-2015-3218, CVE-2015-3255, CVE-2015-3256, CVE-2015-4625