FreeBSD : PostgreSQL -- minor security problems. (a0182578-6e00-11e5-a90c-0026551a22dc)

Medium Nessus Plugin ID 86320


The remote FreeBSD host is missing one or more security-related updates.


PostgreSQL project reports :

Two security issues have been fixed in this release which affect users of specific PostgreSQL features.

- CVE-2015-5289 json or jsonb input values constructed from arbitrary user input can crash the PostgreSQL server and cause a denial of service.

- CVE-2015-5288: The crypt() function included with the optional pgCrypto extension could be exploited to read a few additional bytes of memory. No working exploit for this issue has been developed.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 86320

File Name: freebsd_pkg_a01825786e0011e5a90c0026551a22dc.nasl

Version: $Revision: 1.6 $

Type: local

Published: 2015/10/09

Modified: 2016/02/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:postgresql90-server, p-cpe:/a:freebsd:freebsd:postgresql91-server, p-cpe:/a:freebsd:freebsd:postgresql92-server, p-cpe:/a:freebsd:freebsd:postgresql93-server, p-cpe:/a:freebsd:freebsd:postgresql94-server, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/10/08

Vulnerability Publication Date: 2015/10/08

Reference Information

CVE: CVE-2015-5288, CVE-2015-5289