Squid 3.5.x < 3.5.9 Multiple DoS

High Nessus Plugin ID 86191


The remote proxy server is potentially affected by multiple denial of service vulnerabilities.


According to its banner, the version of Squid running on the remote host is 3.5.x prior to 3.5.9. It is, therefore, potentially affected by the following vulnerabilities:

- A denial of service vulnerability exists in file bio.cc when handling hello messages. A remote attacker can exploit this to cause an infinite loop. (VulnDB 127754)

- An integer overflow condition exists in file bio.cc due to improper validation of user-supplied input. A remote attacker can exploit this to crash the proxy, resulting in a denial of service. (VulnDB 127762)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number. The patch released to address these issues does not update the version given in the banner. If the patch has been applied properly, and the service has been restarted, consider this to be a false positive.


Upgrade to Squid version 3.5.9 or later, or apply the vendor-supplied patch.

See Also



Plugin Details

Severity: High

ID: 86191

File Name: squid_3_5_9.nasl

Version: $Revision: 1.3 $

Type: remote

Family: Firewalls

Published: 2015/09/29

Modified: 2016/06/20

Dependencies: 49692

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: www/squid, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/09/17

Vulnerability Publication Date: 2015/09/16

Reference Information

OSVDB: 127754, 127762