FreeBSD : codeigniter -- multiple vulnerabilities (f838dcb4-656f-11e5-9909-002590263bf5)

High Nessus Plugin ID 86181


The remote FreeBSD host is missing a security-related update.


The CodeIgniter changelog reports :

Security: The xor_encode() method in the Encrypt Class has been removed. The Encrypt Class now requires the Mcrypt extension to be installed.

Security: The Session Library now uses HMAC authentication instead of a simple MD5 checksum.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 86181

File Name: freebsd_pkg_f838dcb4656f11e59909002590263bf5.nasl

Version: $Revision: 2.1 $

Type: local

Published: 2015/09/28

Modified: 2015/09/28

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:codeigniter, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/09/28

Vulnerability Publication Date: 2014/06/05