openSUSE Security Update : cyrus-imapd (openSUSE-2015-605)

Medium Nessus Plugin ID 86138


The remote openSUSE host is missing a security update.


This recommended update provides version 2.3.19 of cyrus-imapd

- Security fix: handle urlfetch range starting outside message range

- Disable use of SSLv2/SSLv3

- Support for Berkeley DB 5.x (thanks Ondrej Sury)

- Support for newer glibc versions (thanks Thomas Jarosch)

- Fixed bug #3465: support for perl 5.14 (thanks [email protected])

- Fixed bug #3640: reject NULL bytes in headers on LMTP delivery (thanks Julien Coloos)


Update the affected cyrus-imapd packages.

See Also

Plugin Details

Severity: Medium

ID: 86138

File Name: openSUSE-2015-605.nasl

Version: $Revision: 2.1 $

Type: local

Agent: unix

Published: 2015/09/25

Modified: 2015/09/25

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:cyrus-imapd, p-cpe:/a:novell:opensuse:cyrus-imapd-debuginfo, p-cpe:/a:novell:opensuse:cyrus-imapd-debugsource, p-cpe:/a:novell:opensuse:cyrus-imapd-devel, p-cpe:/a:novell:opensuse:perl-Cyrus-IMAP, p-cpe:/a:novell:opensuse:perl-Cyrus-IMAP-debuginfo, p-cpe:/a:novell:opensuse:perl-Cyrus-SIEVE-managesieve, p-cpe:/a:novell:opensuse:perl-Cyrus-SIEVE-managesieve-debuginfo, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/09/16