FreeBSD : libssh2 -- denial of service vulnerability (9770d6ac-614d-11e5-b379-14dae9d210b8)

Medium Nessus Plugin ID 86080


The remote FreeBSD host is missing a security-related update.


Mariusz Ziulek reports :

A malicious attacker could man in the middle a real server and cause libssh2 using clients to crash (denial of service) or otherwise read and use completely unintended memory areas in this process.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 86080

File Name: freebsd_pkg_9770d6ac614d11e5b37914dae9d210b8.nasl

Version: $Revision: 2.1 $

Type: local

Published: 2015/09/23

Modified: 2015/09/23

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:libssh2, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/09/22

Vulnerability Publication Date: 2015/01/25

Reference Information

CVE: CVE-2015-1782