Joomla! 3.4.x < 3.4.4 Login Module XSS

Medium Nessus Plugin ID 86020

Synopsis

The remote web server contains a PHP application that is affected by a cross-site scripting vulnerability.

Description

According to its self-reported version number, the Joomla! installation running on the remote web server is 3.4.x prior to 3.4.4.
It is, therefore, affected a cross-site (XSS) scripting vulnerability in the login module due to improper validation of user-supplied input.
An unauthenticated, remote attacker can exploit this to execute arbitrary script code in a user's browser session.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Joomla! version 3.4.4 or later.

See Also

http://www.nessus.org/u?6c020854

http://www.nessus.org/u?9b2f149a

Plugin Details

Severity: Medium

ID: 86020

File Name: joomla_344.nasl

Version: $Revision: 1.8 $

Type: remote

Published: 2015/09/18

Modified: 2017/05/19

Dependencies: 21142

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:joomla:joomla\!

Required KB Items: installed_sw/Joomla!, www/PHP, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/09/08

Vulnerability Publication Date: 2015/09/08

Reference Information

CVE: CVE-2015-6939

BID: 76750