IBM HTTP Server 6.1 <= 184.108.40.206 (FP47) / 7.0 < 220.127.116.11 (FP39) / 8.0 < 18.104.22.168 (FP12) / 8.5 < 22.214.171.124 (FP7) Multiple Vulnerabilities
High Nessus Plugin ID 86018
SynopsisThe remote IBM HTTP Server is affected by multiple vulnerabilities.
DescriptionThe IBM HTTP Server running on the remote host is version 6.1 prior to or equal to 126.96.36.199, 7.0 prior to 188.8.131.52, 8.0 prior to 184.108.40.206, or 8.5 prior to 220.127.116.11. It is, therefore, potentially affected by multiple vulnerabilities :
- An overflow condition exists in the XML_GetBuffer() function in xmlparse.c due to improper validation of user-supplied input when handling compressed XML content. An attacker can exploit this to cause a buffer overflow, resulting in the execution of arbitrary code.
- A denial of service vulnerability exists when processing an ECParameters structure due to an infinite loop that occurs when a specified curve is over a malformed binary polynomial field. A remote attacker can exploit this to perform a denial of service against any system that processes public keys, certificate requests, or certificates. This includes TLS clients and TLS servers with client authentication enabled. (CVE-2015-1788)
- An information disclosure vulnerability exists that allows an unauthenticated, remote attacker to identify the proxy server software by reading the HTTP 'Via' header. (CVE-2015-1932)
- A flaw exists in the chunked transfer coding implementation due to a failure to properly parse chunk headers. A remote attacker can exploit this to conduct HTTP request smuggling attacks. (CVE-2015-3183)
- An unspecified flaw exists that allows an unauthenticated, remote attacker to spoof servlets or disclose sensitive information. (CVE-2015-4938)
- An overflow condition exists in the Administration Server due to improper validation of user-supplied input. An attacker can exploit this, via a specially crafted request, to cause a stack-based buffer overflow, resulting in a denial of service condition or the execution of arbitrary code. (CVE-2015-4947)
Note that :
- CVE-2015-1788 does not affect the 6.1 and 7.0 branches.
- CVE-2015-1932 and CVE-2015-4938 do not affect the 6.1 branch.
SolutionApply IBM 7.0 Fix Pack 39 (18.104.22.168) / 8.0 Fix Pack 12 (22.214.171.124) / 8.5 Fix Pack 7 (126.96.36.199) or later. Alternatively, apply the Interim Fixes as recommended in the vendor advisory.
In the case of the 6.1 branch, apply IBM 6.1 Fix Pack 47 (188.8.131.52) and then apply Interim Fixes PI39833 and PI45596.