Splunk Enterprise 6.2.x < 6.2.6 / Splunk Light 6.2.x < 6.2.6 Splunk Web XSS

Medium Nessus Plugin ID 85962

Synopsis

The remote web server is running an application that is affected by a cross-site scripting vulnerability.

Description

According to its version number, the instance of Splunk hosted on the remote web server is Splunk Enterprise 6.2.x prior to 6.2.6 or Splunk Light 6.2.x prior to 6.2.6. It is, therefore, affected by a cross-site scripting vulnerability in the Splunk Web component due to improper validation of user-supplied input. A remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Splunk Enterprise 6.2.6 / Splunk Light 6.2.6 or later.

See Also

https://www.splunk.com/view/SP-CAAAPAM

Plugin Details

Severity: Medium

ID: 85962

File Name: splunk_626.nasl

Version: 1.8

Type: remote

Published: 2015/09/16

Modified: 2018/11/15

Dependencies: 47619, 49069

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:splunk:splunk

Required KB Items: installed_sw/Splunk

Patch Publication Date: 2015/09/14

Vulnerability Publication Date: 2015/09/14