Splunk Enterprise 6.2.x < 6.2.6 / Splunk Light 6.2.x < 6.2.6 Splunk Web XSS

medium Nessus Plugin ID 85962


The remote web server is running an application that is affected by a cross-site scripting vulnerability.


According to its version number, the instance of Splunk hosted on the remote web server is Splunk Enterprise 6.2.x prior to 6.2.6 or Splunk Light 6.2.x prior to 6.2.6. It is, therefore, affected by a cross-site scripting vulnerability in the Splunk Web component due to improper validation of user-supplied input. A remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Splunk Enterprise 6.2.6 / Splunk Light 6.2.6 or later.

See Also


Plugin Details

Severity: Medium

ID: 85962

File Name: splunk_626.nasl

Version: 1.9

Type: remote

Published: 9/16/2015

Updated: 1/19/2021

Risk Information


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.7

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:splunk:splunk

Required KB Items: installed_sw/Splunk

Patch Publication Date: 9/14/2015

Vulnerability Publication Date: 9/14/2015