openSUSE Security Update : tor (openSUSE-2015-569)

Low Nessus Plugin ID 85838


The remote openSUSE host is missing a security update.


Tor was updated to fix one logging privacy issue.

The following issue was fixed :

- Malformed hostnames in socks5 requests were written to the log regardless of SafeLogging option (CWE-532) [boo#943362]


Update the affected tor packages.

See Also

Plugin Details

Severity: Low

ID: 85838

File Name: openSUSE-2015-569.nasl

Version: $Revision: 2.1 $

Type: local

Agent: unix

Published: 2015/09/08

Modified: 2015/09/08

Dependencies: 12634

Risk Information

Risk Factor: Low

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:tor, p-cpe:/a:novell:opensuse:tor-debuginfo, p-cpe:/a:novell:opensuse:tor-debugsource, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/08/27