FreeBSD : powerdns -- denial of service (55c43f5b-5190-11e5-9ad8-14dae9d210b8)

High Nessus Plugin ID 85757


The remote FreeBSD host is missing a security-related update.


PowerDNS reports :

A bug was found in our DNS packet parsing/generation code, which, when exploited, can cause individual threads (disabling service) or whole processes (allowing a supervisor to restart them) to crash with just one or a few query packets.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 85757

File Name: freebsd_pkg_55c43f5b519011e59ad814dae9d210b8.nasl

Version: $Revision: 2.1 $

Type: local

Published: 2015/09/03

Modified: 2015/09/03

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:powerdns, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/09/02

Vulnerability Publication Date: 2015/09/02

Reference Information

CVE: CVE-2015-5230