Fortinet FortiOS 5.0.x < 5.0.9 Telnet / SSH Username XSS

Medium Nessus Plugin ID 85742


The remote host is affected by a cross-site scripting vulnerability.


The remote host is running a version of Fortinet FortiOS 5.0.x prior to 5.0.9. It is, therefore, affected by a cross-site scripting vulnerability due to improper validation of user-supplied input to the Telnet and SSH usernames. An unauthenticated, remote attacker can exploit this vulnerability to execute arbitrary script code in the context of the current user.


Upgrade to Fortinet FortiOS 5.0.9 or later.

See Also

Plugin Details

Severity: Medium

ID: 85742

File Name: fortios_www_interface_ssh_telnet_username_xss.nasl

Version: $Revision: 1.3 $

Type: local

Family: Firewalls

Published: 2015/09/02

Modified: 2017/06/23

Dependencies: 73522

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/o:fortinet:fortios

Required KB Items: Host/Fortigate/model, Host/Fortigate/version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/01/28

Vulnerability Publication Date: 2015/01/28

Reference Information

OSVDB: 125008