FreeBSD : OpenSSH -- PermitRootLogin may allow password connections with 'without-password' (27fed73e-484f-11e5-825f-c80aa9043978)

High Nessus Plugin ID 85593


The remote FreeBSD host is missing a security-related update.


OpenSSH 7.0 contained a logic error in PermitRootLogin= prohibit-password/without-password that could, depending on compile-time configuration, permit password authentication to root while preventing other forms of authentication. This problem was reported by Mantas Mikulenas.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 85593

File Name: freebsd_pkg_27fed73e484f11e5825fc80aa9043978.nasl

Version: $Revision: 2.1 $

Type: local

Published: 2015/08/24

Modified: 2015/08/24

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:openssh-portable, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/08/21

Vulnerability Publication Date: 2015/08/20