Oracle MySQL 5.6.x < 5.6.24 Multiple Vulnerabilities (July 2015 CPU) (October 2015 CPU)

Medium Nessus Plugin ID 85538

Synopsis

The remote host is missing one or more security updates.

Description

The version of Oracle MySQL installed on the remote host is 5.6.x prior to 5.6.24. It is, therefore, affected by the following vulnerabilities :

- Multiple information disclosure vulnerabilities exist in the following subcomponents which can be exploited by an authenticated, remote attacker to gain access to sensitive information :
- Pluggable Auth (CVE-2015-4737)
- Security:Privileges (CVE-2015-2620)

- Multiple denial of service vulnerabilities exist in the following subcomponents which can be exploited by an authenticated, remote attacker :
- DML (CVE-2015-4905)
- InnoDB (CVE-2015-4866)
- Optimizer (CVE-2015-4757)

Solution

Apply the appropriate patch according to the July 2015 and October 2015 Oracle Critical Patch Update advisories.

See Also

http://www.nessus.org/u?178c8ed1

http://www.nessus.org/u?1de82df5

https://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-24.html

https://support.oracle.com/epmos/faces/DocumentDisplay?id=2024204.1

https://support.oracle.com/epmos/faces/DocumentDisplay?id=2048227.1

http://www.nessus.org/u?d18c2a85

http://www.nessus.org/u?75a4a4fb

Plugin Details

Severity: Medium

ID: 85538

File Name: mysql_5_6_24_rpm.nasl

Version: 1.10

Type: local

Family: Databases

Published: 2015/08/19

Updated: 2018/11/15

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql, p-cpe:/a:amazon:linux:mysql, p-cpe:/a:centos:centos:mysql, p-cpe:/a:fedoraproject:fedora:mysql, p-cpe:/a:fermilab:scientific_linux:mysql, p-cpe:/a:novell:opensuse:mysql, p-cpe:/a:novell:suse_linux:mysql, p-cpe:/a:oracle:linux:mysql, p-cpe:/a:redhat:enterprise_linux:mysql

Required KB Items: Host/local_checks_enabled

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/07/14

Vulnerability Publication Date: 2015/07/14

Reference Information

CVE: CVE-2015-2620, CVE-2015-4737, CVE-2015-4757, CVE-2015-4866, CVE-2015-4905

BID: 75759, 75802, 75837, 77132, 77143