FreeBSD : py-foolscap -- local file inclusion (09fff0d9-4126-11e5-9f01-14dae9d210b8)

High Nessus Plugin ID 85366


The remote FreeBSD host is missing one or more security-related updates.


Brian Warner reports :

The 'flappserver' feature was found to have a vulnerability in the service-lookup code which, when combined with an attacker who has the ability to write files to a location where the flappserver process could read them, would allow that attacker to obtain control of the flappserver process.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 85366

File Name: freebsd_pkg_09fff0d9412611e59f0114dae9d210b8.nasl

Version: $Revision: 2.1 $

Type: local

Published: 2015/08/13

Modified: 2015/08/13

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:py27-foolscap, p-cpe:/a:freebsd:freebsd:py32-foolscap, p-cpe:/a:freebsd:freebsd:py33-foolscap, p-cpe:/a:freebsd:freebsd:py34-foolscap, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/08/12

Vulnerability Publication Date: 2014/09/23