FreeBSD : net-snmp -- snmp_pdu_parse() function incomplete initialization (381183e8-3798-11e5-9970-14dae9d210b8)

High Nessus Plugin ID 85172


The remote FreeBSD host is missing a security-related update.


Qinghao Tang reports :

Incompletely initialized vulnerability exists in the function 'snmp_pdu_parse()' of 'snmp_api.c', and remote attackers can cause memory leak, DOS and possible command executions by sending malicious packets.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 85172

File Name: freebsd_pkg_381183e8379811e5997014dae9d210b8.nasl

Version: $Revision: 2.3 $

Type: local

Published: 2015/08/03

Modified: 2016/05/26

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:net-snmp, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/07/31

Vulnerability Publication Date: 2015/04/11

Reference Information

CVE: CVE-2015-5621