openSUSE Security Update : libidn (openSUSE-2015-497)

High Nessus Plugin ID 84866


The remote openSUSE host is missing a security update.


libidn was updated to version 1.31 to fix one security issue.

This security issue was fixed :

- CVE-2015-2059: Out-of-bounds read with stringprep on invalid UTF-8 (bsc#923241).


Update the affected libidn packages.

See Also

Plugin Details

Severity: High

ID: 84866

File Name: openSUSE-2015-497.nasl

Version: $Revision: 2.2 $

Type: local

Agent: unix

Published: 2015/07/20

Modified: 2015/08/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libidn-debugsource, p-cpe:/a:novell:opensuse:libidn-devel, p-cpe:/a:novell:opensuse:libidn-tools, p-cpe:/a:novell:opensuse:libidn-tools-debuginfo, p-cpe:/a:novell:opensuse:libidn11, p-cpe:/a:novell:opensuse:libidn11-32bit, p-cpe:/a:novell:opensuse:libidn11-debuginfo, p-cpe:/a:novell:opensuse:libidn11-debuginfo-32bit, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/07/10

Reference Information

CVE: CVE-2015-2059