ISC BIND 9.7.x < 9.9.7-P1 / 9.10.x < 9.10.2-P2 Resolver DNSSEC Validation DoS

high Nessus Plugin ID 84728

Synopsis

The remote name server is affected by a denial of service vulnerability.

Description

According to its self-reported version number, the remote installation of BIND is potentially affected by a denial of service vulnerability, when configured as a recursive resolver with DNSSEC validation, due to an error that occurs during the validation of specially crafted zone data returned in an answer to a recursive query. A remote attacker can exploit this, by causing a query to be performed against a maliciously constructed zone, to crash the resolver.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to BIND version 9.9.7-P1 / 9.10.2-P2 or later.

Alternatively, as a workaround, disable DNSSEC validation by setting the 'dnssec-validation' option to no.

See Also

https://kb.isc.org/docs/aa-01267

https://kb.isc.org/article/AA-01270

https://kb.isc.org/article/AA-01269

Plugin Details

Severity: High

ID: 84728

File Name: bind9_9102_p2.nasl

Version: 1.10

Type: remote

Family: DNS

Published: 7/14/2015

Updated: 11/15/2018

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:isc:bind

Required KB Items: bind/version, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 7/7/2015

Vulnerability Publication Date: 7/7/2015

Reference Information

CVE: CVE-2015-4620

BID: 75588