openSUSE Security Update : rubygem-RedCloth (openSUSE-2015-457)

Medium Nessus Plugin ID 84532


The remote openSUSE host is missing a security update.


rubygem-RedCloth was updated to fix one security issue.

The following vulnerability was fixed :

CVE-2012-6684: A cross-site scripting (XSS) vulnerability allowed remote attackers to inject arbitrary web script or HTML via a javascript: URI (boo#912212)


Update the affected rubygem-RedCloth packages.

See Also

Plugin Details

Severity: Medium

ID: 84532

File Name: openSUSE-2015-457.nasl

Version: $Revision: 2.1 $

Type: local

Agent: unix

Published: 2015/07/06

Modified: 2015/07/06

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:rubygem-RedCloth, p-cpe:/a:novell:opensuse:rubygem-RedCloth-debuginfo, p-cpe:/a:novell:opensuse:rubygem-RedCloth-debugsource, p-cpe:/a:novell:opensuse:rubygem-RedCloth-testsuite, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/06/24

Reference Information

CVE: CVE-2012-6684