FreeBSD : node, iojs, and v8 -- denial of service (864e6f75-2372-11e5-86ff-14dae9d210b8)

High Nessus Plugin ID 84524


The remote FreeBSD host is missing one or more security-related updates.


node reports :

This release of Node.js fixes a bug that triggers an out-of-band write in V8's utf-8 decoder. This bug impacts all Buffer to String conversions. This is an important security update as this bug can be used to cause a denial of service attack.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 84524

File Name: freebsd_pkg_864e6f75237211e586ff14dae9d210b8.nasl

Version: $Revision: 2.4 $

Type: local

Published: 2015/07/06

Modified: 2015/07/14

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:iojs, p-cpe:/a:freebsd:freebsd:node, p-cpe:/a:freebsd:freebsd:node-devel, p-cpe:/a:freebsd:freebsd:v8, p-cpe:/a:freebsd:freebsd:v8-devel, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/07/06

Vulnerability Publication Date: 2015/07/03

Reference Information

CVE: CVE-2015-5380