FreeBSD : chicken -- Potential buffer overrun in string-translate* (0da404ad-1891-11e5-a1cf-002590263bf5)

Medium Nessus Plugin ID 84321


The remote FreeBSD host is missing a security-related update.


chicken developer Peter Bex reports :

Using gcc's Address Sanitizer, it was discovered that the string-translate* procedure from the data-structures unit can scan beyond the input string's length up to the length of the source strings in the map that's passed to string-translate*. This issue was fixed in master 8a46020, and it will make its way into CHICKEN 4.10.

This bug is present in all released versions of CHICKEN.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 84321

File Name: freebsd_pkg_0da404ad189111e5a1cf002590263bf5.nasl

Version: $Revision: 2.4 $

Type: local

Published: 2015/06/23

Modified: 2018/01/31

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:chicken, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/06/22

Vulnerability Publication Date: 2015/06/15

Reference Information

CVE: CVE-2015-4556