FreeBSD : libzmq4 -- V3 protocol handler vulnerable to downgrade attacks (10a6d0aa-0b1c-11e5-bb90-002590263bf5)

Medium Nessus Plugin ID 84104


The remote FreeBSD host is missing one or more security-related updates.


Pieter Hintjens reports :

It is easy to bypass the security mechanism in 4.1.0 and 4.0.5 by sending a ZMTP v2 or earlier header. The library accepts such connections without applying its security mechanism.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 84104

File Name: freebsd_pkg_10a6d0aa0b1c11e5bb90002590263bf5.nasl

Version: $Revision: 2.1 $

Type: local

Published: 2015/06/11

Modified: 2015/06/11

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:libzmq4, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/06/10

Vulnerability Publication Date: 2014/12/04

Reference Information

CVE: CVE-2014-9721