GLSA-201504-06 : X.Org X Server: Multiple vulnerabilities

Medium Nessus Plugin ID 84071


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201504-06 (X.Org X Server: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in X.Org X Server. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker could possibly execute arbitrary code with the privileges of the process or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All X.Org X Server users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=x11-base/xorg-server-1.12.4-r4'

See Also

Plugin Details

Severity: Medium

ID: 84071

File Name: gentoo_GLSA-201504-06.nasl

Version: $Revision: 2.1 $

Type: local

Published: 2015/06/10

Modified: 2015/06/10

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:xorg-server, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/04/17

Reference Information

CVE: CVE-2014-8091, CVE-2014-8092, CVE-2014-8093, CVE-2014-8094, CVE-2014-8095, CVE-2014-8096, CVE-2014-8097, CVE-2014-8098, CVE-2014-8099, CVE-2014-8100, CVE-2014-8101, CVE-2014-8102, CVE-2014-8103, CVE-2015-0255

BID: 71595, 71596, 71597, 71598, 71599, 71600, 71601, 71602, 71603, 71604, 71605, 71606, 71608, 72578

GLSA: 201504-06