FreeBSD : strongswan -- Denial-of-service and potential remote code execution vulnerability (55363e65-0e71-11e5-8027-00167671dd1d)

High Nessus Plugin ID 84069


The remote FreeBSD host is missing a security-related update.


StrongSwan Project reports

A denial-of-service and potential remote code execution vulnerability triggered by crafted IKE messages was discovered in strongSwan.
Versions 5.2.2 and 5.3.0 are affected.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 84069

File Name: freebsd_pkg_55363e650e7111e5802700167671dd1d.nasl

Version: $Revision: 2.4 $

Type: local

Published: 2015/06/10

Modified: 2018/02/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:strongswan, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/06/09

Vulnerability Publication Date: 2015/05/15

Reference Information

CVE: CVE-2015-3991