FreeBSD : tidy -- heap-buffer-overflow (bd1ab7a5-0e01-11e5-9976-a0f3c100ae18)

Medium Nessus Plugin ID 84044


The remote FreeBSD host is missing one or more security-related updates.


Geoff McLane reports :

tidy is affected by a write out of bounds when processing malformed html files.

This issue could be abused on server side applications that use php-tidy extension with user input.

The issue was confirmed, analyzed, and fixed by the tidy5 maintainer.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 84044

File Name: freebsd_pkg_bd1ab7a50e0111e59976a0f3c100ae18.nasl

Version: $Revision: 2.6 $

Type: local

Published: 2015/06/09

Modified: 2017/07/06

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:tidy-devel, p-cpe:/a:freebsd:freebsd:tidy-html5, p-cpe:/a:freebsd:freebsd:tidy-lib, p-cpe:/a:freebsd:freebsd:tidy4, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/06/08

Vulnerability Publication Date: 2015/06/03

Reference Information

CVE: CVE-2015-5522, CVE-2015-5523