openSUSE Security Update : fuse (openSUSE-2015-401)

Low Nessus Plugin ID 84014


The remote openSUSE host is missing a security update.


- Update to version 2.9.4

- fix exec environment for mount and umount (bsc#931452, CVE-2015-3202)

- properly restore the default signal handler

- fix directory file handle passed to	ioctl() method.

- fix for uids/gids larger than 2147483647

- initialize stat buffer passed to getattr() and fgetattr()


Update the affected fuse packages.

See Also

Plugin Details

Severity: Low

ID: 84014

File Name: openSUSE-2015-401.nasl

Version: $Revision: 2.3 $

Type: local

Agent: unix

Published: 2015/06/08

Modified: 2015/11/05

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 3.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:fuse, p-cpe:/a:novell:opensuse:fuse-debuginfo, p-cpe:/a:novell:opensuse:fuse-debugsource, p-cpe:/a:novell:opensuse:fuse-devel, p-cpe:/a:novell:opensuse:fuse-devel-static, p-cpe:/a:novell:opensuse:libfuse2, p-cpe:/a:novell:opensuse:libfuse2-32bit, p-cpe:/a:novell:opensuse:libfuse2-debuginfo, p-cpe:/a:novell:opensuse:libfuse2-debuginfo-32bit, p-cpe:/a:novell:opensuse:libulockmgr1, p-cpe:/a:novell:opensuse:libulockmgr1-debuginfo, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/05/29

Exploitable With

Core Impact

Reference Information

CVE: CVE-2015-3202