openSUSE Security Update : mysql-connector-java (openSUSE-2015-389)

Medium Nessus Plugin ID 83914


The remote openSUSE host is missing a security update.


mysql-connector-java was updated to 5.1.35 to fix one security issue and a number of bugs.

The following vulnerability was fixed :

- CVE-2015-2575: Difficult to exploit vulnerability allows successful authenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some MySQL Connectors accessible data as well as read access to a subset of MySQL Connectors accessible data.

In addition, mysql-connector-java was updated to 5.1.35 to fix a number of upstream bugs, details of which listed in CHANGES as well as


Update the affected mysql-connector-java package.

See Also

Plugin Details

Severity: Medium

ID: 83914

File Name: openSUSE-2015-389.nasl

Version: $Revision: 2.4 $

Type: local

Agent: unix

Published: 2015/06/01

Modified: 2015/07/19

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.9

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:mysql-connector-java, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2015/05/24

Reference Information

CVE: CVE-2015-2575