SUSE SLED11 / SLES11 Security Update : libqt4 (SUSE-SU-2014:1121-1)

High Nessus Plugin ID 83635


The remote SUSE host is missing one or more security updates.


This update of the QT4 QSSL interface makes it select a set of default ciphers that is recommended for current usage. This update is needed for Konqueror to restrict its cipher set when using https.

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Software Development Kit 11 SP3 :

zypper in -t patch sdksp3-libqt4-20140902-9683

SUSE Linux Enterprise Server 11 SP3 for VMware :

zypper in -t patch slessp3-libqt4-20140902-9683

SUSE Linux Enterprise Server 11 SP3 :

zypper in -t patch slessp3-libqt4-20140902-9683

SUSE Linux Enterprise Desktop 11 SP3 :

zypper in -t patch sledsp3-libqt4-20140902-9683

To bring your system up-to-date, use 'zypper patch'.

See Also

Plugin Details

Severity: High

ID: 83635

File Name: suse_SU-2014-1121-1.nasl

Version: $Revision: 2.2 $

Type: local

Agent: unix

Published: 2015/05/20

Modified: 2015/09/29

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:libQtWebKit4, p-cpe:/a:novell:suse_linux:libqt4, p-cpe:/a:novell:suse_linux:libqt4-qt3support, p-cpe:/a:novell:suse_linux:libqt4-sql, p-cpe:/a:novell:suse_linux:libqt4-sql-mysql, p-cpe:/a:novell:suse_linux:libqt4-sql-postgresql, p-cpe:/a:novell:suse_linux:libqt4-sql-sqlite, p-cpe:/a:novell:suse_linux:libqt4-sql-unixODBC, p-cpe:/a:novell:suse_linux:libqt4-x11, p-cpe:/a:novell:suse_linux:qt4-x11-tools, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2014/09/11